Where do I find the Lully app?

The Sleep Guardian works with iOS devices only. To use the Lully app, you must have an iPhone (4s or newer), iPad (Air, Mini, 3rd gen, 4th gen or newer), or iPod touch (5th gen or newer) with iOS 7 or newer.

You can find the Lully App on the Apple App Store. Click here on your iOS device or simply type "Lully" on the App Store to find the Lully app.

Have more questions? Submit a request

0 Comments

Article is closed for comments.
Powered by Zendesk